Remove Slider from all but front page

Home Forums BeFit Theme Support Remove Slider from all but front page

This topic contains 5 replies, has 4 voices, and was last updated by  Forum Moderator 2 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #14896

    Christopher Robock
    Member
    • Topics: 1
    • Replies: 0
    • Total: 1
    Member since: November 19, 2015

    Hi there.

    I just bought the BeFit theme, and it’s great, but I would like to know how I can remove the slider from most pages. I’d like it to be only on the front page of my site, and not on all the other pages. Can this be done?

    #15073

    SKT Themes
    Keymaster
    • Topics: 2
    • Replies: 6147
    • Total: 6149
    Member since: June 12, 2013

    Hi,

    Yes kindly go to Appearance>Theme Options>Homepage slider>drop down is there to disable slider from inner pages.

    Regards,
    Shri

    #26973

    Gail
    Member
    • Topics: 0
    • Replies: 7
    • Total: 7
    Member since: March 5, 2016

    The suggestion from Shri will remove the slider on most other pages. However, we have a front page that is a static page, with our blog on another page (called “news”). The home page slider and 4 boxes appear on both pages. To remove it from the “news” page, SKT support suggested using Dashboard > Appearance > Theme Options > Basic Settings > custom CSS and entering CSS to hide the home page slider and 4 boxes on the “news” page.

    The CSS would be:
    body.blog .slider-main, body.blog section#wrapone {
    display:none;
    }

    However, even though the CSS successfully hides these items, I believe that the browser will still fetch the images and execute the JavaScript. (I could be wrong on this.) This adds an unnecessary burden to both the web server and browser. The PHP should really not generate the objects in the first place.

    #27027

    Forum Moderator
    Member
    • Topics: 0
    • Replies: 16998
    • Total: 16998
    Member since: August 16, 2013

    Hi Gail,

    I understood your issue and here is the reason behind that.

    You are selecting the post page from setting>>reading>>post page and hence the slider and homepage boxes appears on post page. Instead of this we have a template for blog pages so that you don’t need to select post page from Setting>>Reading.

    Kindly go to Setting>>Reading>>Select your latest posts

    After that go to Pages>>News click on edit option. You will find the “Page Attributes” box in right hand side. There is a templates for blog page like Blog Left Sidebar, Right Sidebar..etc., select any one option and save the page.

    Regards,
    Brad

    #28138

    Gail
    Member
    • Topics: 0
    • Replies: 7
    • Total: 7
    Member since: March 5, 2016

    Thanks for your reply.
    I followed your directions. The home page slider, 4 boxes, and my own content for the “home” page did not appear on the “home” page.
    I realized that we have a static page named “home”; this was our home page specified in Settings > Reading. The URL without a page name (directory “/”) correctly showed the SKT BeFit Home Page Slide and 4 boxes, but not the content of our static page “/home”. Our static page “/home” showed its content but not the SKT Home Page Slider or 4 boxes.

    I did the following:

    1. Removed my custom CSS that made the slider & 4 boxes “hidden”
    2. Copied the content of the static page named “home” and pasted it into Section 1 in Theme Options > Sections
    3. Edited our menu: item “Home” was pointing to page “home”; replaced that with “custom URL” menu item pointing to “/”.

    Now it displays correctly. Thanks.

    #28520

    Forum Moderator
    Member
    • Topics: 0
    • Replies: 16998
    • Total: 16998
    Member since: August 16, 2013

    Okay cool 🙂

    Regards,
    Brad

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.