Menu error

This topic contains 10 replies, has 3 voices, and was last updated by  Forum Moderator 2 years, 8 months ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #14784

    Richard Keitz
    Member
    • Topics: 7
    • Replies: 23
    • Total: 30
    Member since: April 24, 2015

    When a menu item is selected all of the sub-items turn green. The user can no longer see the sub-items turn from white to green as the mouse scrolls the items.

    This happens under the “Our Work” and “About Us” menu items. For some reason the items under “Careers” work as they are supposed to work.

    http://www.compoconst.com/

    #14786

    Richard Keitz
    Member
    • Topics: 7
    • Replies: 23
    • Total: 30
    Member since: April 24, 2015

    I noticed this web site using Photo Session has the same problem under the “Activities” menu item:

    http://jerseyitguy.co.uk/AS/08VanNesteJ/website2/wordpress/summer-camp

    #14851

    SKT Themes
    Keymaster
    • Topics: 2
    • Replies: 6328
    • Total: 6330
    Member since: June 12, 2013

    Will solve this in Photo Session in next update.

    Regards,
    Shri

    #14879

    Richard Keitz
    Member
    • Topics: 7
    • Replies: 23
    • Total: 30
    Member since: April 24, 2015

    When will there be an update?

    I took another look at why “Careers” works while “Our Projects” and “About Us” does not work and discovered that if I make the top menu a custom link to a URL instead of to a Page the menu works? Maybe this will help you find out where the problem is, but for me my work around is fine.

    Under “About Us” the sub-menu item “Community Involvement” wraps. Can you point me to the location in the source where I can increase the sub-menu width about 3 characters? Thanks

    Rich Keitz

    #15081

    SKT Themes
    Keymaster
    • Topics: 2
    • Replies: 6328
    • Total: 6330
    Member since: June 12, 2013

    Hi Rich,

    Sure show us your website URl and we can guide you.

    Regards,
    Shri

    #15096

    Richard Keitz
    Member
    • Topics: 7
    • Replies: 23
    • Total: 30
    Member since: April 24, 2015

    http://www.compoconst.com/

    Also, where can I adjust the color of the submenu background? It’s stuck on #FFFFFF with no transparency. I would like to make it the same as the header background and transparency.

    #15162

    SKT Themes
    Keymaster
    • Topics: 2
    • Replies: 6328
    • Total: 6330
    Member since: June 12, 2013

    #site-nav ul li:hover ul { background-color:rgba(0, 0, 0, 0.6)}

    Add this in Appearance>Theme Options>Layout Settings>Custom CSS

    Regards,
    Shri

    #15762

    Richard Keitz
    Member
    • Topics: 7
    • Replies: 23
    • Total: 30
    Member since: April 24, 2015

    I added: #site-nav ul li:hover ul { background-color:rgba(0, 0, 0, 0.6)}

    and it did not seem to have any effect.

    #15829

    SKT Themes
    Keymaster
    • Topics: 2
    • Replies: 6328
    • Total: 6330
    Member since: June 12, 2013

    Apply !important at the end of 0.6 and then close it with ; (semi colon)

    Regards,
    Shri

    #16391

    Richard Keitz
    Member
    • Topics: 7
    • Replies: 23
    • Total: 30
    Member since: April 24, 2015

    Shri,
    That didn’t work

    #16586

    Forum Moderator
    Member
    • Topics: 0
    • Replies: 17349
    • Total: 17349
    Member since: August 16, 2013

    Hi Richard,

    Kindly go to Appearance>Theme Options>Layout Settings>Custom CSS
    Replace this css code with your code:

    #site-nav ul li:hover ul {background:rgba(0,0,0,0.6); display:block; left:0; position:absolute; top:30px; width:190px; z-index:10;}

    Hope it helps.

    Regards,
    Shri

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.